EE2021 - Projector Display Unavailable
Incident Report for Teaching Spaces Status
Resolved
This incident has been resolved.
Posted Jan 06, 2023 - 14:20 GMT
Investigating
We have identified an issue with the projector display in EE2021. We are hoping to ensure a permanent fix by the upcoming semester.

To ensure the display is functional in the room a temporary TV trolley has been installed for use.
Posted Nov 09, 2022 - 09:06 GMT
This incident affected: St John's - Edward Elgar Building (EE) (EE2021).