UA 1001 Joel Richards Conference Suite - Lectern Mic Unavailable
Incident Report for Teaching Spaces Status
Resolved
Joel Richards Suite Lectern currently unavailable. A TV trolley and PA system have been installed in it's place on a temporary basis.
Posted Dec 08, 2022 - 09:57 GMT
Investigating
We have identified an issue in UA 1001 Joel Richards Conference Suite with the lectern microphone not functioning correctly, where the sound is intermittently disconnecting and quiet.

To mitigate the issue there is a handheld microphone available to use in the room or a lapel microphone can be collected from the Arena reception.

We are working with the Arena to get a date scheduled with our AV partner to fully upgrade the room equipment.
Posted Nov 18, 2022 - 09:56 GMT
This incident affected: Severn Campus - University Arena (UA) (UA1001 - Joel Richards Conference Suite).