EGA - Lectern touch panels Unavailable
Incident Report for Teaching Spaces Status
Resolved
This incident has been resolved.
Posted Oct 07, 2024 - 09:23 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 27, 2024 - 13:53 BST
Update
We are continuing to investigate this issue.
Posted Aug 27, 2024 - 10:25 BST
Investigating
We have identified an issue in EGA with the lectern control panels. We are currently working to identify the cause of the issue.

To mitigate the problem we advise using one of the mobile display trolleys for the time being while we resolve the issue. Apologies for any inconvenience caused.

If you experience any issues whilst using the AV equipment in the room please contact the IT Service Desk, selecting option 1 via:
- 7500 from a lectern telephone handset
- +44(0)1905 85 7500 from any other telephone
Posted Aug 27, 2024 - 10:25 BST