EE 2010 - Room is offline #10074

Incident Report for Teaching Spaces Status

Resolved

This incident has been resolved.
Posted Aug 12, 2025 - 16:52 BST

Update

We are continuing to investigate this issue.
Posted Aug 07, 2025 - 13:11 BST

Update

We are continuing to investigate this issue.
Posted Aug 07, 2025 - 11:49 BST

Investigating

A hardware failure has been identified in EE 2010. Unfortunately, users are unable to access the lectern in this room.

If you face any further difficulties with the AV equipment in this room, please get in touch with the IT Service Desk at (01905 85 7500).
Posted Aug 07, 2025 - 11:49 BST
This incident affected: St John's - Edward Elgar Building (EE) (EE2010).