EE G031 - Screen Issue
Incident Report for Teaching Spaces Status
Resolved
This incident has been resolved.
Posted Mar 08, 2024 - 09:48 GMT
Identified
The network port on the interactive screen in EEG031 has failed and we have scheduled engineers to come and replace the screen.
Posted Feb 06, 2024 - 12:29 GMT
This incident affected: St John's - Edward Elgar Building (EE) (EEG031).