EE 1107 - Power Issue
Incident Report for Teaching Spaces Status
Resolved
This incident has been resolved, an issue with the fuse for this teaching space has been identified and fixed.
Posted Jan 25, 2024 - 15:27 GMT
Investigating
We have discovered an issue with the power for the equipment in this room, we are currently working to restore the functionality of this teaching space.
Posted Jan 16, 2024 - 14:00 GMT
This incident affected: St John's - Edward Elgar Building (EE) (EE1107).