UA 1001 Joel Richards Conference Suite - Lectern Unavailable
Incident Report for Teaching Spaces Status
Resolved
This incident has been resolved. New equipment has been installed and the room is now operational.
Posted Mar 17, 2023 - 10:23 GMT
Identified
We have identified an issue in UA 1001 (Joel Richards Conference Suite) with the lectern, currently this is unable to be used.

We've installed a TV trolley and a PA system as a temporary solution.

If you experience any issues whilst using the AV equipment in the room please contact the IT Service Desk, selecting option 1 via:
- 7500 from a lectern telephone handset
- +44(0)1905 85 7500 from any other telephone
Posted Dec 08, 2022 - 09:52 GMT
This incident affected: Severn Campus - University Arena (UA) (UA1001 - Joel Richards Conference Suite).