CH 2006 - Display Intermittent

Incident Report for Teaching Spaces Status

Resolved

This incident has been resolved.
Posted Feb 17, 2025 - 10:30 GMT

Identified

We have identified an issue in CH 2006 with the main display disconnecting.

If you experience issues getting content to display on the main display, please contact the IT Service Desk (01905 85 7500) and we will attend the room to assist.
Posted Dec 18, 2024 - 17:04 GMT
This incident affected: City Campus - Charles Hasting's Building (CH) (CH2006).