EE 1104 - Switching External Inputs

Incident Report for Teaching Spaces Status

Update

We are continuing to investigate this issue.
Posted May 20, 2026 - 13:35 BST

Investigating

An issue has been detected in EE 1104; inputs are failing to switch, thus affecting BYOD laptops, document cameras, etc.

However, the PC is displaying on the Main Display.

If you experience any issues with the AV equipment in this room please contact the IT Service Desk (01905 85 7500).
Posted May 01, 2026 - 17:13 BST
This incident affects: St John's - Edward Elgar Building (EE) (EE1104).