EEG119 - Button Panel
Incident Report for Teaching Spaces Status
Resolved
This incident has been resolved.
Posted Dec 21, 2023 - 14:53 GMT
Investigating
We are aware of the Control Panel on the lectern failing, this means that no lights are currently showing on the panel and the screen no longer turns on and off with the panel. Please use power button on the screen itself until this problem is resolved. thank you
Posted Nov 17, 2023 - 10:32 GMT
This incident affected: St John's - Edward Elgar Building (EE) (EEG119).